Electric water heater won't heat


  #1  
Old 04-05-16, 08:26 AM
B
Member
Thread Starter
Join Date: Apr 2016
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Unhappy Electric water heater won't heat

It's a Richmond 53 gallon from 2012. It won't heat. It has 2 new thermostats a new limit switch and 2 new elements.
 
  #2  
Old 04-05-16, 08:33 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 27,932
Received 2,218 Upvotes on 1,980 Posts
Is the heater getting power?
 
  #3  
Old 04-05-16, 08:37 AM
B
Member
Thread Starter
Join Date: Apr 2016
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Has power and the breaker is good
 
  #4  
Old 04-05-16, 08:42 AM
ray2047's Avatar
Member
Join Date: Mar 2006
Location: USA
Posts: 29,711
Upvotes: 0
Received 15 Upvotes on 13 Posts
Has power and the breaker is good
If you used a non contact tester then you don't actually know if either of those things are true. If you used a multimeter let us know how you did the tests.
 
  #5  
Old 04-05-16, 04:22 PM
A
Member
Join Date: Mar 2010
Location: USA
Posts: 4,556
Upvotes: 0
Received 285 Upvotes on 260 Posts
Hint: When the heater is first turned on, just the upper element should heat up.

Do not turn on power until water has gushed from a hot faucet upstairs for a minute.
 
  #6  
Old 04-10-16, 04:02 PM
CasualJoe's Avatar
Member
Join Date: Jan 2010
Location: United States
Posts: 9,875
Received 186 Upvotes on 167 Posts
Has power and the breaker is good
Can you verify that you have 240 volts across the two terminals on the top element?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: