Gas water heater pilot won't light

Reply

  #1  
Old 08-24-19, 10:41 AM
Member
Thread Starter
Join Date: Aug 2019
Posts: 2
Received 0 Votes on 0 Posts
Question Gas water heater pilot won't light

I opened up and pulled the gas heating/combustion unit out of the bottom of the tank and got the pilot to light and stay lit when it was outside the tank.

The spark is fine, the pilot gas is fine, and, again, it stayed lit. But when I reinstalled it, I kept trying to light it and it won't light at all.

The bottom of the tank got wet with about 1-1/4" water a couple of weeks ago due to basement flooding during a very intense storm. There is no water in the bottom of the tank now, though, so I would think all should be fine.

Suggestions?
 
Sponsored Links
  #2  
Old 08-25-19, 05:48 PM
Member
Thread Starter
Join Date: Aug 2019
Posts: 2
Received 0 Votes on 0 Posts
Anybody? Anybody?

Bueller? Bueller?

Would love to have hot water again. Have been taking cold showers for two weeks now as I don't want to spring for the repair guy. I know I can fix this if someone can just help me figure out why on earth it would light perfectly outside the tank, but when placed back in the tank, nada, no luck.

Thoughts? Guesses?

If nobody can help, is okay. I'll just do my Wim Hof "Ice Man" breathing and continue with cold showers without the ability to follow up with a nice warm one
 

Last edited by SimpleFix; 08-25-19 at 05:52 PM. Reason: typo correct and added a line
  #3  
Old 08-26-19, 04:39 PM
Member
Join Date: Oct 2008
Location: USA
Posts: 2,881
Received 5 Votes on 5 Posts
This is a conundrum. If I were physically there, I might (or probably, might not) be able to help - but not, so far, over the internet. Best to call a local plumber whose references you've checked. The flooding incident adds some additional uncertainty.
 
  #4  
Old 08-26-19, 04:52 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 52,685
Received 343 Votes on 321 Posts
(thread moved to water heater forum)

Like Gil said..... it's tough without being there.

However.... I have an idea. The pilot works fine outside the heater but when reinstalled it won't light. That might be because there is water in the pilot tube. Depending on the angle... the water moves. I'd remove the pilot tube and orifice... if removable.... and blow air thru it.

Other than that.... once submerged.... the burner assy should be replaced.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: