Gas Valve on my water heater has no lights at all!


  #1  
Old 05-12-24, 08:48 AM
R
Member
Thread Starter
Join Date: May 2024
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts
Gas Valve on my water heater has no lights at all!

The White Rodgers gas valve on my water heater has no lights at all. Power supply is good. No response to pressing red and blue arrows together. Do these units burn out to the point that no error lights will light up? Or has the venting fan unit gone bad? The water heater is 13 years old.
Thank you,
Aleksandar
 
  #2  
Old 05-12-24, 04:36 PM
B
Member
Join Date: Oct 2015
Location: Ct.,USA
Posts: 3,287
Received 307 Upvotes on 272 Posts
WR model number would be helpful.
 
  #3  
Old 05-13-24, 06:43 AM
R
Member
Thread Starter
Join Date: May 2024
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts
See please attached picture.
 
  #4  
Old 05-13-24, 12:51 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,415
Received 4,049 Upvotes on 3,632 Posts
Welcome to the forums.

I checked your posts (coding) and did not see a picture.
How to insert pictures.

Most gas valves....even with power venters... get the power from the pilot light.
So if the pilot is not lit.... the valve will appear dead.
 
  #5  
Old 05-13-24, 05:09 PM
R
Member
Thread Starter
Join Date: May 2024
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts


 

Last edited by PJmax; 05-14-24 at 01:56 PM.
  #6  
Old 05-13-24, 05:12 PM
R
Member
Thread Starter
Join Date: May 2024
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts
Is there the way to know if it is just the pilot light?
 
  #7  
Old 05-14-24, 02:23 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,415
Received 4,049 Upvotes on 3,632 Posts
I thought you were posting the water heater model number.
Going to need to it.

Your water is uses intermittent ignition lit by a hot surface igniter.
There is no pilot.
It may be a problem with the draft inducer/pressure switch.

Intellivent manual - pdf
W/R gas valve troubleshooting - pdf
 
  #8  
Old 05-14-24, 03:30 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,415
Received 4,049 Upvotes on 3,632 Posts
You said power checked good..... where ?
You need to make sure it's on the plug that connects to the valve.
The Intellivent link has all the diagnostics in it.
 
  #9  
Old 05-16-24, 05:12 PM
R
Member
Thread Starter
Join Date: May 2024
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thank you so much for the manual. The plug that connects the valve has voltage. The Air Pressure Switch tested negative for electrical continuity! Can that be a possible reason that valve doesn't turn on?
 
  #10  
Old 05-16-24, 05:19 PM
R
Member
Thread Starter
Join Date: May 2024
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts
  #11  
Old 05-17-24, 10:12 AM
R
Member
Thread Starter
Join Date: May 2024
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts
  #12  
Old 05-19-24, 03:46 PM
CasualJoe's Avatar
Member
Join Date: Jan 2010
Location: United States
Posts: 9,880
Received 187 Upvotes on 168 Posts
See please attached picture.
​​​​​​​What picture? I see no picture.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: