Smelly water after media change


  #1  
Old 05-26-07, 06:24 AM
R
Member
Thread Starter
Join Date: May 2007
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
Smelly water after media change

Hi y'all. I just rented this house with a zeolite sediment filter and the landlord had the service tech out the other day to replace the zeolite. And now the water smells, kinda like a chemical. It didn't do this before he came out. Is this supposed to go away after awhile, or do I need to get the landlord to have the service guy back out here?
 
  #2  
Old 07-26-07, 09:21 AM
R
Member
Thread Starter
Join Date: May 2007
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
bump. Anyone???
 
  #3  
Old 07-26-07, 08:19 PM
G
Member
Join Date: Jun 2007
Location: Utah
Posts: 267
Upvotes: 0
Received 0 Upvotes on 0 Posts
Zeolite

Which zeolite was used ?
 
  #4  
Old 07-27-07, 11:25 AM
R
Member
Thread Starter
Join Date: May 2007
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
It was chemsorb, I believe.
 
  #5  
Old 07-27-07, 05:29 PM
G
Member
Join Date: Jun 2007
Location: Utah
Posts: 267
Upvotes: 0
Received 0 Upvotes on 0 Posts
Chemsorb

There shouldn't be a noticeable odor after rebedding. If he didn't rinse it properly, there might be some dust residue, with an earthy odor.

Run your bathtub on cold only for 20 minutes and see if the odor is significantly reduced.

If not, have your service tech come back and fix the problem.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: