New water softener install questions


  #1  
Old 10-19-08, 02:09 PM
C
Member
Thread Starter
Join Date: Apr 2007
Posts: 5
Upvotes: 0
Received 0 Upvotes on 0 Posts
New water softener install questions

Hey there,

I just finished all the plumbing yesterday for my new water softener and everything looks good. I have a new unit with an Erie controller that I managed to pick up for cost from a plumbing contractor my Dad deals with. Since the unit is intended for contractors it doesn't come with detailed instructions on install and setup and I don't really know how to start up the system so it can start working.

So here's what happened when I tried on my own. Once all the plumbing was completed I connected the small hose from the resin tank to the brine tank and added a bag of salt to the brine tank. Turned the water back on and opened the bypass valves. Not sure what to do next so I toggled through the electronic controller until it said "Regenerate in 5sec" and waited. Moments later water came shooting out with force through the top of the valve where it's indicated "drain"

So what did I do wrong? Why would water shoot out of a drain valve with so much force?

What are the steps I should take to start up the system properly?
 
  #2  
Old 10-20-08, 08:29 AM
biermech's Avatar
Member
Join Date: Aug 2008
Location: USA
Posts: 2,007
Upvotes: 0
Received 3 Upvotes on 3 Posts
Sounds to me you did not hook up the drain line. You half to fill the unit slowly when brand new.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: