kinetico k30'20 water runs out drain all the time, no suction in float water


  #1  
Old 09-10-09, 08:57 PM
M
Member
Thread Starter
Join Date: Sep 2009
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
kinetico k30'20 no suction,top wheel wont spin,water runs to drain in all cycle

hi 1st timer.... I have a k3020 kinetico. the serial# on one of the 2 tanks says 321366. they are tan.
Problem. I dont notice the top wheel moving at all. it seems to stay in one spot. also when I push down with a screwdriver to regen it, no matter what cycle its in water constantly flows from the tube going to my drain. also I took all the salt out of the big container/cleaned all the crap and just filled it about 4 inches above the base and turned on. the water level stays the same. nothing makes it raise or lower. A year ago gorden bros replaced the float, k-30 hy cup, control disk, repaired gearlog level 1, checked metering, cleaned valves......................................... now it has the above 3 problems... any help would be great...thanks
 

Last edited by markandy; 09-10-09 at 09:40 PM.
  #2  
Old 09-12-09, 05:04 AM
A
Member
Join Date: Dec 2005
Location: Northwest Ohio
Posts: 1,478
Upvotes: 0
Received 0 Upvotes on 0 Posts
Originally Posted by markandy View Post
hi 1st timer.... I have a k3020 kinetico. the serial# on one of the 2 tanks says 321366. they are tan.
Problem. I dont notice the top wheel moving at all. it seems to stay in one spot. also when I push down with a screwdriver to regen it, no matter what cycle its in water constantly flows from the tube going to my drain. also I took all the salt out of the big container/cleaned all the crap and just filled it about 4 inches above the base and turned on. the water level stays the same. nothing makes it raise or lower. A year ago gorden bros replaced the float, k-30 hy cup, control disk, repaired gearlog level 1, checked metering, cleaned valves......................................... now it has the above 3 problems... any help would be great...thanks
That disk doesn't move anyway, the control disk beneath it does. There might be something that is preventing the metereing gear from turning. The level one most likely needs to be cleaned out. If the system is stuck in backwash, then the brine level will not change.

Andy Christensen, CWS-II
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: