Kinetico 4060S OD Macrolite

Reply

  #1  
Old 03-16-17, 08:22 PM
J
Member
Thread Starter
Join Date: Mar 2017
Location: United States
Posts: 1
Received 0 Votes on 0 Posts
Kinetico 4060S OD Macrolite

I believe there may be a problem with my kinetico's resin...doesn't seem to be filtering iron like I believe it should.

I purchased a home 2 years ago which was built 10 years prior with the above kinetico system. Home is on a well. I have never lived in a home with well water or a water softener.

The brine tank was empty of salt when we purchased, and I do not know how long water was being used without salt in the tank. Well water in our area is pretty high in iron, I'm told by neighbors, but I have not had the water tested for iron, just bacteria.

There is no pre-filter, but there is a post-filter (4x10, I believe). I have to change the post filter every 6-8 weeks due to iron buildup and low pressure in the house. When I change it, it typically has a thick layer of iron circumferentially around the filter. Last summer I noticed the disc was not readable and covered with iron. I took apart the top assembly after watching some youtube videos, cleaned the iron off, and put it all back together. The disc is again covered with iron, although you can read the "5" imprinted on the disc.

Also, from time to time we'll have very salty water come out of the tap and/or fridge.

I'm not sure where to start troubleshooting this. There is one kinetico dealer/repair in my area, and have heard bad and shady stories from multiple people who have dealt with him, so I'd like to avoid his apparently less-than-ethical business, if I can.

Any help would be appreciated. How do I know if the media is fouled and needs to be replaced? How do I know if it's an issue with a cone that I've read about. Should I be seeing that much iron buildup on my post filter? I have neighbors who say they have to change theirs 2-3 times yearly...I'm easily 6-8 times.

Thanks again.

I've attached photos of the disc and my setup. There are two filters....the one on the right goes to the outside (irrigation and outdoor spigots) and the one on the left to the home water. There's also an inline UV filter.

Name:  image1 (1).jpg
Views: 547
Size:  50.1 KBName:  image2.jpg
Views: 566
Size:  49.1 KBName:  image1 (2).jpg
Views: 523
Size:  27.9 KB
 
Sponsored Links
  #2  
Old 03-21-17, 07:42 AM
biermech's Avatar
Member
Join Date: Aug 2008
Location: USA
Posts: 2,009
Received 2 Votes on 2 Posts
First thing that needs to be done is a water test (iron, hardness and pH at lest). I would rebed the system. Getting that much iron through the system tells me it is not working very well. You can find some good Kinetico info on watersoftenersuperstore.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: