fleck 5600 econominder head problem

Reply

  #1  
Old 06-24-19, 01:10 PM
tsnider's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: USA
Posts: 153
fleck 5600 econominder head problem

We have a Fleck 5600 econominder head. The electricity went off for about 5 hours the other day. I reset the time without an issue. Now after several days the window has shown brine position without moving. The manual regeneration knob won't rotate clockwise, even with a fair amount of force.

Seems that something is wonky with the head now. Is anything broke? I'm wondering what can I do to get the head working properly again? Thanks.
 
Sponsored Links
  #2  
Old 06-26-19, 10:16 AM
Akpsdvan's Avatar
Member
Join Date: Mar 2010
Location: Alaska
Posts: 1,935
You can remove the head from the rest of the valve body and that will remove pressure from main piston and brine piston.
It might be easier to turn the knob through its cleaning steps.
Also while the power head is off check to make sure the gears are correct and no shafts have broken, in the years have found the shaft for the brine cam to have broken and that throws off the brine cam and then the main cam ....
Power heads are kind of cheap, and depending one might be able to find one on Ebay as a replacement to the one you have.
 
  #3  
Old 07-08-19, 07:21 AM
tsnider's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: USA
Posts: 153
Turns out we got the plumber out. The piston was froze and the motor stripped several (yeah multiple) gears. So we got a new head. (it's only money sigh) )
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes