zoeller pump - float stuck

Reply

  #1  
Old 05-12-07, 05:54 AM
I
Member
Thread Starter
Join Date: Feb 2005
Location: illinois
Posts: 95
Received 0 Votes on 0 Posts
zoeller pump - float stuck

I have zoeller sump pump (M-53, I think) with a vertical float. The pump is working fine whenever it turns on. But what I have noticed is, when the water trickles down really really slowly in to the pit, the float raises all the way up but stays in that position and water keeps raising even above the normal usual pumping level. But if I give a tap on the pipe then I see the switch activated and motor starts pumping. This problem does not happen all the time.

Is the switch faulty? I found the switch in a local hardware store for some $28. I find it expensive because the pump it self they are selling for $125.
 
Sponsored Links
  #2  
Old 05-12-07, 07:42 AM
P
Member
Join Date: Oct 2001
Location: So. Cal
Posts: 1,051
Received 0 Votes on 0 Posts
Zoeller biulds a great pump, but their switches leave a little to be desired.
I would guess that the switch is bad, or getting there. They're not too hard to change, but make sure everything is sealed really well. You don't want water inside the switch.
Ron
 
  #3  
Old 05-12-07, 07:50 AM
I
Member
Thread Starter
Join Date: Feb 2005
Location: illinois
Posts: 95
Received 0 Votes on 0 Posts
Hi Pumpman,

Can I replace the zoeller switch with a piggyback one? I saw in another post that some one did it. But I am not sure how they deactivated the one that is attached to the pump.

Any ideas?
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: